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About iRecovery Stick 
 

Welcome to Paraben’s iRecovery Stick!  

 

This program allows investigators to recover data from iPhones including text messages 
and more. 

 

The data can be recovered either from the iPhone device directly or from the IPhone 
back-up files.  

All iPhone OS are supported including iPhones 1.x-4.x. 
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Getting Started 

System Requirements 

 

The following requirements must be met to use iRecovery Stick: 

 iRecovery Stick requires a Windows XP or newer operating system. 

 To use the Export to Excel feature, Microsoft Excel must be installed on your 
computer and you must add the .Net Framework programming tools during the 
installation process. 
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Application User Interface 

Understanding the User Interface 

 

The iRecovery Stick interface includes the following parts: 

o The Main page: This page contains information about iRecovery Stick and three 
buttons that let you open the existing workspace, start recovery process from the 
iPhone device or iTunes backup files. 

o The Data page: On this page, the recovered data and other backup data 
received from the device is displayed. 

o The Main menu: The menu provides access to the main functionality of 
Paraben's iRecovery Stick. 

 

Main Page 

 

The Main page of iRecovery Stick opens at the program start-up. 

 

It contains the following elements: 

o A tool bar. 

o Short description of iRecovery Stick. 

o Three icons: Start Recovery, Open Workspace, and Start Import from iTunes 
Backup.  

o A link to the Data page if there is any data in the workspace. 

 

From the Main page, you can do the following: 

o Start recovery process from the iPhone device or iTunes backup files. 

o Define program options. 

o Open an existing workspace.  

o Move to the Data page. 

o Rename the currently opened workspace. 

o Export workspace data to Excel. 

 

Data Page 

The Data page opens when data recovery process finishes, you open a workspace or 
you click the Back to Data link on the Main page. 

The Data page contains the following elements: 

o A list of data categories. 

o The Data pane in which data is displayed. 

o The name of the device from which data was recovered. 

o A Search field.  

o The Details pane, including the Properties tab, the Bookmarks tab, and the 
Search Results tab. 

o A link to the Main page. 
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From the Data page, you can do the following: 

o View the recovered data. 

o View the properties of the device from which you recovered data. 

o Search text data in the workspace. 

o Create and access bookmarks. 

o Define program options. 

o Open an existing workspace.  

o Go to the Main page. 

o Save the open workspace using a different name. 

o Export workspace data to Excel. 
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Main Menu 

 

File Menu 

 

The File Menu contains basic file options for working with iRecovery Stick.  

Menu Item Description 

Open 
Workspace 

Opens a saved workspace. 

Save As Saves the open workspace under a different name. 

Start Recovery Closes the open workspace and displays a screen from which you 
can select a device to scan.  

Start Import Starts the import of iPhone backup files. 

Export to Excel Exports the content of the workspace as an MS Excel (.xls) file. 

Exit Shuts the iRecovery Stick down. 

 

 

View Menu 

 

The View menu lets you display tools in the iRecovery Stick user interface. 

Menu Item Description 

Bookmarks Opens the Bookmarks pane. 

 

 

Tools Menu 

 

The Tools menu lets you check for iRecovery Stick updates and define logging and 
folder options. 

Menu Item Description 

Options Lets you define logging options and the default folder for saved 
workspaces. 

Check for 
Updates 

Connects to the Paraben’s site to download updates.  

 

 

Help Menu 

 

The Help menu gives access to this help file, information about the iRecovery Stick 
application, and displays registration data. 

Menu Item Description 

Help Opens iRecovery Stick user documentation. 

About Qt Provides data about the Qt tool, licensed for use in iRecovery Stick. 

About Displays the iRecovery Stick description and the version number. 
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Recovering Data  
 

iRecovery Stick allows you to recover data either from iPhone device or from iPhone 
back-up. 

 

CAUTION: iRecovery Stick places recovered data in a temporary workspace that is 
automatically created in the workspace folder. The folder location is defined in the Options 
menu and has a Workspace<number>.ds name. When you close the workspace, you must save 
it or you will lose the data.  

 

Recovering Data from the iPhone Device 

 

The iRecovery Stick acquires data and recovers the deleted data from iPhone devices.  
This section explains how to recover data from your iPhone. 

 

Before the recovery process starts, do the following:  

1. Turn on the device. 

2. Ensure that the device battery is completely charged.  

3. Ensure that iTunes drivers are installed on your computer. Its installation is 
performed automatically at the first iRecovery Stick connection.  

4. Connect the iPhone to the computer with a data cable.  

 

To recover data from the iPhone: 

 

1. Do one of the following: 

 Click Start Recovery on the Main page.  

 Click File > Start Recovery. 

 Press F5. 

 

2. Click on the image of the device you want to scan. If multiple devices are 
connected to your computer, multiple images are displayed.  

3. The recovery process starts. 

 
NOTE: If your device doesn’t appear in the list in several seconds after the connection, try to disconnect it 
and then connect back again. 
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Recovering Data from iTunes Backup Files 

 

The iRecovery Stick imports data from the iPhone backup files created by iTunes and 
recovers deleted data stored in them. 

 

To import the backup file: 

1. Do one of the following: 

 Click File > Start Import. 

 On the Main page, click the Start Import from iTunes Backup icon. 

2. Choose the plug-in for importing. 

3. Navigate to the Manifest.plist file, then click Open.  
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Working with Workspaces 

About Workspaces 

 

A workspace is a file with a .ds extension that contains information recovered from a 
single iPhone device.  

Creating a New Workspace 

 

When you start data recovery, iRecovery Stick creates a new temporary workspace. 
The workspace is named Workspace<number>.ds. By default, the workspace is saved 
in the current Windows user folder. The workspace is also updated after you create a 
bookmark. You can change the default location where a workspace is saved, and you 
can use the Save As function to relocate and rename a saved workspace. 

 

To create a workspace: 

1. Start the data recovery process. See Recovering Data from iPhone. 

2. Click File > Save As, then click Save.  

To define the default workspace folder: 

1. Click Tools > Options, then type the new name and browse to the folder you 
want to use. 

2. Click Save. 

To change the name of a workspace: 

1. Open the workspace that you want to change. 

2. Click File > Save As. 

3. Browse to the location where you want to save the workspace, then type the new 
name. 

Opening an Existing Workspace 

 

Workspaces created by iRecovery Stick (*.ds files) can be opened from the user 
interface. 

1. To open an existing workspace, do one of the following: 

o On the Main page, click on the Open Workspace button. 

o In the File menu, select the Open Workspace item.  

o Press Ctrl+O. 

 

When you open a new workspace, the currently open workspace closes.  Unsaved 
information is lost. 

 

Closing a Workspace 

 

The workspace closes when any other workspace opens or iRecovery Stick shuts 
down. 
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Viewing iPhone Data 
 

The iRecovery Stick receives two types of data from the iPhone device or iPhone 
backup: 

 Recovered deleted data. 

 Other backup data. 

 

Recovered Data 

 

iRecovery Stick recovers the following types of data:  

 

 Address Book records 

 Address Book images 

 Calendar records  

 Call History records 

 Notes 

 SMS 

 

To view the recovered data, select the Recovered Data category. 

The recovered data is displayed in records and is not parsed.  

 

The list of records is displayed in the Data pane.  

 

You can click on a recovered record to view its contents. The record opens in not 
parsed format in the File viewer to the right of the Data pane.  

 

To change the code page for the opened record, select the required encoding in the 
drop-down list.  

 

To close the File viewer for the record, click Close.  
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Other Data 

 

Other data received from the iPhone backup includes the following parts: 

 

o Device properties: The properties of the iPhone from which data was recovered 
are displayed in the Properties tab of the Details pane. Click View Details to 
open the details pane. 

 

o Data categories: In the left of the Data page, the categories of the back-up data 
are displayed. Click the category name to view its contents. 

 

o Back-up data: Acquired backup data is displayed in the right part of the Data 
page. Data representation depends on its format. 
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Text data includes the following categories: 

o Contacts: The device phonebook. 

o Messages: The device SMS messages. 

o Call History: The device call logs. 

o Organizer: The device calendar, memos, and so on. 

o Internet Data: Includes Safari suspend state, Safari Bookmarks, Safari History, 
Cookies, Delivery Accounts, Mail Accounts, and Youtube bookmarks. 

o Other Data: This data includes Properties, Maps Directions, Maps Bookmarks, 
Maps History, and Dynamic Text. 

 

Data from each category is displayed in a grid to the right of the Data page. There can 
be several tabs in the grid if data contains sub-categories, such as a Calendar and 
Notes for the Organizer.  
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Multimedia data includes Graphics category. 

 

This data is displayed as thumbnails. You can click a file to view it. The image opens in 
the same pane. If necessary (for big images), it scales to fit the window size. To return 
to thumbnails, click the scaled image.  

You can also use external viewers to view multimedia data. To open the image in the 
external viewer, right-click on it and select Open with. 



 

 16 

 

 



 

 17 

 

 

Searching Data 
 

The iRecovery Stick allows you to search for text data in a workspace. 

 

To search text data: 

1. On the Data page, in the Search Text field (in the upper right corner of the 
page), type the search string text. 

2. Click Search or press Enter.  

3. The search progress is displayed in the Search Results tab of the Details pane. 
Click Abort to stop the search. 

4. When the search finishes, the search results are displayed in the Search 
Results tab of the Details pane. Each result is displayed as <Category 
name>\<Sub-category (tab) name>.  

5. Double click the search result to navigate to it. 
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Exporting Data 

Exporting Data to MS Excel 

 

You can export data from the workspace as an Excel workbook (.xls file). 

 

To export data: 

1. Click File > Export to Excel. 

2. Click Browse to navigate to the destination folder and name the exported file. 

3. Check Open file after generation to open the exported file. 

4. Click Export. 
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Bookmarks 
A Bookmark is a pointer to data stored in the workspace. 

Bookmarks include the following information:  

o Item (the name of the first cell of the row to which the bookmark is pointing)  

o Name (the name of the bookmark)  

o Details (the description of the bookmark)  

Accessing Bookmarks 

 

Bookmarks are displayed in the Bookmarks tab of the Details pane. 

To view bookmarks:  

1. Do one of the following: 

o Click View > Bookmarks. 

o On the Data page, click View Details (in the bottom left corner).   

2. To view the data, to which bookmark is pointing, double click the bookmark. 

Adding a Bookmark 

To add a bookmark: 

1. Select data to be bookmarked (it can be either a cell of the grid or a row). 

2. Right click the item and select Add to Bookmarks. 

3. Type a name and a description for the bookmark, and then click Save. 

Editing a Bookmark 

To edit a bookmark: 

1. Open the Bookmarks tab of the Details pane. 

2. Right click the bookmark and click Edit, or, from the menu, click Manage > Edit. 

3. Edit the bookmark name and description, and then click Save. 

Deleting a Bookmark 

To delete a bookmark: 

1. Open the Bookmarks tab of the Details pane. 

2. Highlight the bookmark to delete. 

3. Right click the bookmark and select Delete, or, from the menu, click Manage > 
Delete. 

4. Select Delete All to delete all bookmarks. 
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Troubleshooting 

 

The following section provides answers for some common issues that you may 
encounter when using iRecovery Stick. 

 

Problem: The recovery process was broken. The device is in Recovery mode. What do 
I do? 

Solution: Start the Recovery from the device once more. If you don't want to recover 
data, just wait until the device restarts and disconnect it from the computer. 

 
Problem: The iPhone hung. What do I do? 

Solution: Reset the iPhone by holding the sleep/wake button at the top right of the 
device and the home button at the bottom center of the face at the same time. 

 

Problem: The iPhone doesn't connect to the computer. What to do? 

Solution: Please try one of the following: 

 The iPhone battery might need to be recharged.  
 If that doesn't work, disconnect other USB devices from your computer and 

connect the iPhone to a different USB 2.0 port on your computer.  
 If that doesn't work, turn the iPhone off and turn it on again. Press and hold the 

Sleep/Wake button on the top of the iPhone for a few seconds until a red slider 
appears, and then slide the slider. Then press and hold the Sleep/Wake button 
until the Apple logo appears.  

 If that doesn't work, restart your computer and reconnect the iPhone to your 
computer.  

 If that doesn't work, download and install (or reinstall) the latest version of iTunes 
from www.apple.com/itunes.  

http://www.apple.com/itunes
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Creating Log Files 
 

IRecovery Stick has three options for logging support built right in: 

 The Plug-in Log option creates a text file log of the recovery  based on the plug-
in activity. 

 The Serial Log option logs all traffic across the communication port. 

 The GUI Log option logs all events that happened in the iRecovery Stick 
interface during one program session. 

Logs contain useful information for resolving issues and adding support for new models.  

The GUI Log is created automatically and rewritten each time when iRecovery Stick is 
restarted. The Plug-in Log and the Serial Log are optional. The best practice is to leave 
these logging options turned off unless you encounter a problem. Then enable both 
logging options and duplicate the problem. These logs may be needed if you call tech 
support to assist you.  

 

To enable the Plug-in Log and the Serial Log creating: 

1. Click Tools > Options. 

2. Check Serial Logs, Plugin Logs, or both. 

3. Click Save. 

 
NOTE: All logs are created in the user folder (by default, C:\Documents and Settings\{user 
name}\logs). The Plug-in Log and the Serial Log are overwritten when a new recovery process is 
performed using the same plug-in. 
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iRecovery Stick Options 

 

To define iRecovery Stick options, select Tools-Options.  

 

iRecovery Stick options are the following: 

o Logs:  You can define what logs will be created during the recovery process. 
The Plug-in logs option creates a text file log of the recovery process based on 
the plug-in activity and the Serial logs option logs all traffic across the 
communication port. If you have any problems with iRecovery Stick, send the 
logs to Paraben. 

 

o Default Workspace Folder: When recovery process starts, a new workspace is 
automatically created in the default workspace folder. When you close such a 
workspace, you’re proposed to save it under other name. If you don’t want to 
save the workspace, click No and the workspace will be deleted. Make sure that 
there is enough space on the disk, on which the default workspace folder is 
stored.  

 

 
 

Additional Information and Training 

 

Paraben Corporation offers training classes and certifications for professionals seeking 
to solidify their knowledge of handheld device forensics. Coursework trains students on 
PDAs, hybrid devices, SIM cards, and GPS devices and tests that knowledge with 
practical examinations using multiple tools. A Paraben Certified Mobile Examiner 
(PCME) is prepared for whatever the world of handheld forensics throws at them.  

For more information on these training classes or other Paraben forensic tools, please 
visit: www.paraben-forensics.com. 
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